Back to overview
Degraded

Geozone manager is down

May 4, 2026 at 9:07pm UTC
Affected services
Geozone manager

Resolved
May 4, 2026 at 9:07pm UTC

Geozone manager recovered.

Created
May 4, 2026 at 9:07pm UTC

Geozone manager is degraded.